Announcement

Collapse
No announcement yet.

Help! Screen on E-620 is vanished.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! Screen on E-620 is vanished.


  • #2
    Re: Help! Screen on E-620 is vanished.

    Unfortunately this has been reported before, and while not a common fault, is one that requires a return to Olympus for repair.

    Often there is a fixed fee for this repair of about $150 to $200. I may be more economic to get a new body from eBay.

    It's far from ideal, but you could leave in in "AUTO" and use it like a "Point & Shoot" camera.
    Graham

    We often repeat the mistakes we most enjoy...

    Comment


    • #3
      Re: Help! Screen on E-620 is vanished.

      Thank you Graham for your prompt response!
      Yes, I thought the same, to leave in AUTO and use it like a cell, more or less.
      In Argentina is very difficult to get a good technical service and if it exists, the fixed fee would be more expensive that a new body price.
      Thanks again!!

      Comment


      • #4
        Re: Help! Screen on E-620 is vanished.

        Hi Carlos.

        I suspect you and Graham may be correct and the cheapest solution may be to buy a second hand (pre-owned) camera from eBay etc.

        However, this link for Olympus Service in Argentina may be worth checking.
        http://www.olympusamericalatina.com/...s.asp?region=1

        At least you are in the same province.

        Regards.
        Peter

        she looked at me and said "It's official. I hate your camera. It's just so amazing and perfect I want one!"

        E-M10 MK II, E-M5, E-PL1, E-PM2, mZ 12-50, mZ 14-42mm EZ, mZ 17mm f 1.8, mZ 25mm f1.8, mZ 45mm f1.8, mZ 75-300mm II.
        OM1n, OM 50mm f1.8.
        Oly Viewer3, Dxo Pro 11. FastStone.

        Comment


        • #5
          Re: Help! Screen on E-620 is vanished.

          Hi Peter,
          Today I contacted the Olympus service by email. They said me it is impossible that I can check the camera functions watching the settings using the video cable... But that is happening. I don't know. They suggested me to send the camera in order to take a look.
          Just a comment: The LCD display and data from viewfinder vanished when I was using a lens Tamron 28-200mm f/3.8-5.6 with a mount adapter (because is a lens with Nikon mount). I used this lens a lot of time without any problem changing f stop manually.
          Thank you Peter for your reference!

          Comment


          • #6
            Re: Help! Screen on E-620 is vanished.

            I use a 7" LCD TV to view the Live View and it has all the SCP & settings showing on the TV Screen.

            SO You are right and they are wrong.
            Graham

            We often repeat the mistakes we most enjoy...

            Comment


            • #7
              Re: Help! Screen on E-620 is vanished.

              Originally posted by Graham_of_Rainham View Post
              I use a 7" LCD TV to view the Live View and it has all the SCP & settings showing on the TV Screen.

              SO You are right and they are wrong.

              Sorry to hijack the thread but do you know if you can do the same with a e520
              E1, E520, ED14-42, ED 40-150, 70-300, Various legacy including 50mm f2 macro.

              Comment


              • #8
                Re: Help! Screen on E-620 is vanished.

                Originally posted by Homer Simpson View Post
                Sorry to hijack the thread but do you know if you can do the same with a e520
                We have been able to connect a TV to our cameras since the E-3 introduced Live View AV stream

                http://www.olympus.co.jp/en/support/...man_e520_e.pdf
                Graham

                We often repeat the mistakes we most enjoy...

                Comment


                • #9
                  Re: Help! Screen on E-620 is vanished.

                  Hi Carlos,

                  Your English is good.

                  This has happened to me as well, twice actually.

                  First time was on E620. After power on screen showns menus for a few seconds, sometimes longer (> 1 minute), but after a while it will fade and turn black. So the camera is semi-usable if you are fast in operating the menus.

                  Second time it happened was E600 (mechanically identical to the E620). In this case it's really bad, the display goes black almost immediately after ower on. Unless you know the menus by heart or look up a reference, the camera is not usable except Auto.

                  I got repair quote from Olympus Sweden exceeding what the cameras are worth.

                  Shame since they are (were) nice cameras.

                  My Gallery on 500px

                  Comment


                  • #10
                    Re: Help! Screen on E-620 is vanished.

                    Hi Tord,
                    Thank you for share your experience. I will get repair quote from technical service in Argentina in order to know if it is similar or exceeds new body price...
                    I'm very dissapointed because always I have taken care of the camera and it has less than 8000 shootings.
                    I took a look of your pictures. Very nice, beautiful pictures. Congratulations!

                    Comment

                    Working...
                    X